logo.png

Auteur Sujet: Wiring / Electrics  (Lu 1437 fois)

Hors ligne NickM900

  • Bambino
  • *
  • Messages: 6
  • Scottish Guy living in France
    • M900
    • St Uze
Wiring / Electrics
« le: 15 Février 2018 à 16:49:38 »
Hello,

I have a 1999 Monster 900 and have swapped over the instrument cluster (Speedo plus idiot light unit - one unit on this model) with a unit I purchased second hand. This is because I need a unit which reads in KM/H as opposed to MPH as I now live in France.

I now appear to have a problem with both the neutral light and the oil light - neither work! The others all do.

I have swapped over the bulbs but get the same result.

I have had a look around the wiring surrounding the unit and cannot see any reason why these two lights should stop working.

They worked before I swapped over the unit but I tried swapping back the unit and they no longer work on the old unit!

Obviously a wiring issue but I simply cannot pinpoint it or understand why these two lights should not be working (possibly the fuel indicator lamp is also not working but I cannot easily check that one).

Any ideas?

thank you in advance.

et en Francais...

Bonjour,

J'ai un 1999 Monster 900 et j'ai échangé sur le tableau de bord (unité d'éclairage Speedo plus idiot - une unité sur ce modèle) avec une unité que j'ai acheté d'occasion. C'est parce que j'ai besoin d'une unité qui lit en KM / H par opposition à MPH car je vis maintenant en France.

Je semble maintenant avoir un problème à la fois avec la lumière neutre et la lumière d'huile - ni travail! Les autres le font tous.

J'ai troqué les ampoules mais j'ai obtenu le même résultat.

J'ai jeté un coup d'œil autour du câblage entourant l'unité et je ne vois aucune raison pour laquelle ces deux lumières devraient cesser de fonctionner.

Ils ont travaillé avant que je permute l'unité mais j'ai essayé de retourner l'unité et ils ne travaillent plus sur l'ancienne unité!

Évidemment, un problème de câblage, mais je ne peux tout simplement pas le localiser ou comprendre pourquoi ces deux lumières ne devraient pas fonctionner (éventuellement le voyant de carburant ne fonctionne pas, mais je ne peux pas facilement vérifier celui-là).

Des idées?

Merci d'avance.
Always ride with the rubber side down!

Nick

Hors ligne yo

Wiring / Electrics
« Réponse #1 le: 15 Février 2018 à 17:17:50 »
Hi @NickM900,

If I read the 99 M900 wiring schema correctly ...

Neutral : the switch connects the light to +12v when in neutral position.
You can check that :
- the wire Yellow/Green (our Yellow/Gray) receives +12v when in neutral position (using a multimeter)
- the neutral light goes on when you put +12v on this Y/G wire

Oil : the switch connects the light to the ground when oil pressure is too low.
You can check that :
- the wire that comes to the switch (White/Something) gets to the ground when the engine is idle.
- if you connect this wire to the ground, the warning light should go on


Hors ligne ttroncs

Wiring / Electrics
« Réponse #2 le: 15 Février 2018 à 19:12:36 »
The blue wire on the blue button, the red wire ...

Hors ligne Neo14

Wiring / Electrics
« Réponse #3 le: 15 Février 2018 à 19:48:44 »
Merde on s'est fait hacké par les rosbifs :)

Hors ligne Dede

  • Eroe
  • *****
  • Messages: 8229
  • Mascotte du DMF
Wiring / Electrics
« Réponse #4 le: 15 Février 2018 à 20:37:09 »
Merde, après la branlé qu’on a pris en rugby :rolleyes:
Si j’osais, je lui dirais bien où brancher les files. J’ai pas s’ki m’retient...la trouille sûrement  :grin:
Bon ça vaut bien un tit whisky les info de Yo :hum:
Les M sont des SS exhibitionnistes

Hors ligne NickM900

  • Bambino
  • *
  • Messages: 6
  • Scottish Guy living in France
    • M900
    • St Uze
Wiring / Electrics
« Réponse #5 le: 15 Février 2018 à 21:06:22 »
Merci toute le monde!

Je regarde le moto demain apres in bonne Whisky.

Always ride with the rubber side down!

Nick

En ligne JC

  • Grande
  • ****
  • Messages: 1735
    • 12GSA/Alpina 350/M900S
    • Toulouse
Wiring / Electrics
« Réponse #6 le: 15 Février 2018 à 21:07:30 »
Hi Nick,

If you swapped back with the old unit without fixing  the issue, then there is a high likelihood that the unit itself is not the issue...
Since the only stuff you moved in and out is the round multi pin connector, it would point to a wrong contact on a few pins, might be about wires desoldered or twisted pins.

I would suggest to get access to the connector backside by sliding the cable sheath (on the main harness side), then do a visual inspection.
The wires to look for:
    -Neutral light: black + yellow/green
    -Oil light: blue/black + white/yellow
If nothing obvious, then you will need to use a tester to check electrical continuity on theses 4 wires, starting from the connector backside all the way to the bulbs.

BTW, enjoy the Ducati world !  :wink:


Hors ligne waystren

Wiring / Electrics
« Réponse #7 le: 16 Février 2018 à 08:50:09 »
Il vit en France notre ami, donc vous pouvez surement lui causer dans notre langage...

Hors ligne Dede

  • Eroe
  • *****
  • Messages: 8229
  • Mascotte du DMF
Wiring / Electrics
« Réponse #8 le: 16 Février 2018 à 08:58:38 »
non mais comme on dit, la culture, plus on en a, plus on l'étale :rolleyes:

y a un truc aussi avec les cochons dans le même genre, mais j'mange pas d'porc :grin:
Les M sont des SS exhibitionnistes

Hors ligne Rizoto

Wiring / Electrics
« Réponse #9 le: 16 Février 2018 à 10:00:54 »
C'est peut être juste de la correction de répondre en anglais pour être sympa. :wink:

On passe un peu pour des cons avec notre rejets systématique des langues étrangères.
"mets des carbus d'origine tu seras plus emmerdé  :thumbsup:"
samytou le 13 Mars 2018 à 12:58:59

En ligne JC

  • Grande
  • ****
  • Messages: 1735
    • 12GSA/Alpina 350/M900S
    • Toulouse
Wiring / Electrics
« Réponse #10 le: 16 Février 2018 à 10:07:50 »
C'est avant tout, pour des explications un peu complexes, être sûr d'être compris, ne sachant pas le niveau de maitrise de Nick pour notre belle langue...

Hors ligne ttroncs

Wiring / Electrics
« Réponse #11 le: 16 Février 2018 à 10:16:05 »
De toutes façons NickM900 n'est pas Anglais mais Ecossais, ce qui n'est pas la même chose ; parlons-lui donc en Ecossais, à savoir en triplant (au moins) et en roulant tous les R.

Es-tu d'accoRRRd Nick pouRRR agiRRR de la soRRRte ?     :grin:

En ligne JC

  • Grande
  • ****
  • Messages: 1735
    • 12GSA/Alpina 350/M900S
    • Toulouse
Wiring / Electrics
« Réponse #12 le: 16 Février 2018 à 10:23:55 »
S'il n'y avait que le "RRR"... :wink:
Il m'est déjà arrivé de jouer les traducteurs entre écossais (Glasgow) et anglais...
Par exemple, nos amis prononce "mail" comme "meal", donc un anglais va comprendre qu'on lui parle resto quand l'écossais lui parle boulot !  :lol:

Hors ligne ttroncs

Wiring / Electrics
« Réponse #13 le: 16 Février 2018 à 10:42:46 »
Et ma cousine qui est mariée et vie en Angleterre depuis plus de 25 ans ne comprends pas un Gallois sur deux.
Il va falloir que l'on arrête de se flageller en France avec les incompréhensions potentielles entre Nordistes du Nord et Marseillais.   :grin:

Hors ligne waystren

Wiring / Electrics
« Réponse #14 le: 16 Février 2018 à 10:50:17 »
C'est peut être juste de la correction de répondre en anglais pour être sympa. :wink:

On passe un peu pour des cons avec notre rejets systématique des langues étrangères.

Pas trop d'accord, aucun rejet de l'anglais pour ma part, mais quand je poste sur Ducati.ms ou autres
je poste en Anglais, c'est pas au gars qui va me répondre de faire l'effort de traduire et surtout ça reste compréhensible pour tous les autres.

 :wink: